Henkilötunnus Excelissä

Blogiin tulleen kysymyksen innoittamana päätin kirjoittaa postauksen henkilötunnuksen käytöstä Excelissä. Kuten kaikki varmasti tietää, niin henkilötunnus (ent. sosiaaliturvatunnus) koostuu syntymäpäivästä, välimerkistä, joka osoittaa syntymävuosisadan, sekä loppuosasta.

Sen vuoksi pienellä kikkailulla tämän pohjalta voidaan laskea henkilön syntymäpäivä ja esimerkiksi ikä. Jos tulit etsimään vastausta siihen, kuinka laskea ikä henkilötunnuksen perusteella excelissä ja sinulla on perustaidot hallussa, niin tällä kaavalla pääset alkuun:

=IF(MID(B4;7;1)=”-”;YEARFRAC(E4;DATE(”19″&MID(B4;5;2);MID(B4;3;2);LEFT(B4;2));1);IF(MID(B4;7;1)=”A”;YEARFRAC(E4;DATE(”20″&MID(B4;5;2);MID(B4;3;2);LEFT(B4;2));1);NA()))

kokonaisuus

Tämän pitkän ja tuskallisen näköisen kaavan logiikka etenee seuraavasti:

(on muuten pisin tässä blogissa julkaistu kaava tähän mennessä!)

  1. Tarkistetaan, onko seitsemäs merkki ”-” vai ”A”, eli syntymävuosisata
  2. Jos ”-”, syntymäpäivä saadaan kaavalla DATE(”19″&MID(B4;5;2);MID(B4;3;2);LEFT(B4;2))
  3. Ikä lasketaan kaavalla YEARFRAC(E4;DATE(”19″&MID(B4;5;2);MID(B4;3;2);LEFT(B4;2));1), jossa solussa E4 on päivämäärä, jona ikä halutaan. Voit korvata sen kaavalla NOW() jos haluat laskea iän tänään.
  4. Jos seitsemäs merkki on ”A”, henkilö on syntynyt tällä vuosituhannella ja syntymäpäivä saadaan kaavalla DATE(”20″&MID(B4;5;2);MID(B4;3;2);LEFT(B4;2))
  5. Soluun tulee täten henkilön ikä vuosina laskettuna solussa B4 olevan hetun perusteella solussa E4 olevana päivänä

Huomion arvoisia asioita:

Valitettavasti Excel sopii huonosti ennen 1900 vuotta olleiden päivämäärien käsittelyyn, joten tämä kaava ei sovellu 1800-luvulla syntyneiden henkilöiden (esim. Mannerheim ja Sibelius) henkilötunnusten käsittelyyn. Näissä tapauksissa (ja kaikissa, joissa hetun 7. merkki on jotain muuta kuin ”-” tai ”A”) kaava palauttaa virheen #N/A.

Muistathan että henkilötunnusta voi käyttää henkilön yksilöimiseen, mutta ei tunnistamiseen! Lisää aiheesta täältä: http://www.hs.fi/kotimaa/a1477187628597

Mikä on sinun henkilötunnuksesi? Ethän kirjoittaisi sitä kuitenkaan mihinkään julkisesti?

Avoimet kurssit:

4 thoughts on “Henkilötunnus Excelissä

  1. Antti

    Jos saat koodin kopioimalla #NAME errorin niin kirjoita koodin ” ” merkit uudelleen. Ainakin Excel 365 versiolla ne olivat väärän malliset.

    Vastaa
  2. PM

    On olemassa sääntö, että henkilötunnuksen loppuosassa xx0x, xx2x, xx4x, xx6x, xx8x ovat naiset loppuosia ja vastaavasti taas xx1x, xx3x, xx5x, xx7x, xx9x ovat miesten loppuosia. Eli henkilötunnuksen 10. merkki määrittää onko kyseessä mis vai nainen. Millainen kaava tarvitaan, että saadaan näkymään onko henkilötunnus miehen vai naisen?

    Vastaa
    1. Petteri Artikkelin kirjoittaja

      Hei!

      =IF(ISODD(MID(A1;10;1))=TRUE;”Mies”;”Nainen”)

      Tämä kaava katsoo, onko toiseksi viimeinen luku pariton, ja jos on, niin antaa arvon Mies, ja jos ei, niin antaa arvon Nainen.

      Suomenkielisessä versiossa kaava menisi:
      =JOS(PARITON(POIMI.TEKSTI(A1;10;1))=TOSI;”Mies”;”Nainen”)

      Kerro, jos tulee ongelmia!

      Vastaa

Vastaa käyttäjälle Antti Peruuta vastaus

Sähköpostiosoitettasi ei julkaista.