Näin IF-lause toimii

If-lause on suomenkielisessä käännöksessä jos-lause. Kaava toimii yksinkertaisesti siten, että siihen syötetään ehto, jonka jälkeen tulos muodostuu sen mukaan, täyttyykö ehto. Arkielämän tilanteessa tämä voisi olla esim:

Jos tänään sataa, otan mukaan sateenvarjon. Muuten jätän sen kotiin.

Excel-muodossa tämä olisi:

=IF(tänään = sade; otan mukaan sateenvarjon ; jätän sen kotiin)

IF-lause on yksi yleisimmistä kaavoista, joten se löytyy varmasti jokaisesta taulukkolaskentaohjelmasta. Käytännössä IF-lause koostuu kolmesta eri alueesta:

1: Ehto

Tässsä alueessa annetaan kaavan ehto. Arkipäivän  tilanteessa tämä olisi ”Jos tänään sataa”.

Kaavamuodossa tämä olisi =IF(tänään = sade ….

tai suomenkielisessä versiossa =JOS(tänään = sade ….

Vertailua varten voit käyttää seuraavia merkkejä:

= : on yhtäkuin

< : on pienempi kuin

> : on suurempi kuin

<> : on erisuuri kuin

<= : on pienempi tai yhtäsuuri kuin

>= : on suurempi tai yhtäsuuri kuin

 

2. Ehto täyttyy

Tässä alueessa kerrotaan kaavalle, mitä tehdään kun ehto on täyttynyt. Arkipäivän esimerkikssä tämä olisi ”otan mukaan sateenvarjon”.

3. Ehto ei täyty.

Tähän alueeseen tulee arvo, joka annetaan kun ehto ei täyty. Arkipäivän tilanteessa tämä olisi ”Muuten jätän sen kotiin.”

Alueet erotetaan toisistaan puolipisteellä, eli ;-merkillä. Joissain käännöksissä ja joissain versioissa, kuten Google Docsissa käytetään puolipisteen sijaan pilkkua. Muista silloin käyttää desimaalierottimena pistettä!

Vinkki:

Jos haluat jättää solun tyhjäksi, kirjoita kaksi lainausmerkkiä peräkkäin, eli

=IF(A1=1;””;1)

Tämä kaava tarkistaa onko solun A1 sisältö 1, jos on niin jätä tyhjäksi, jos ei niin anna arvo 1.

Tällöin soluun ei jää virheilmoitusta ja taulukko näyttää siistimmältä!

Extra:

Solun A1 sisällön itseisarvo (eli etäisyys nollasta) IF-lauseella.

Screen Shot 06-30-14 at 01.32 PM

=IF(A1>0;A1;-A1)

Eli jos A1 on suurempi kuin 0, arvo on A1. Jos ei, niin arvo on -A1, eli solun A1 vastaluku.

 

 

 

Avoimet kurssit:

3 thoughts on “Näin IF-lause toimii

  1. Antti

    operaattori tarkoittaa erisuurta. Voit lisätä sen tuonne operaattorilistaan…

    Vastaa

Vastaa käyttäjälle Excelgurufi Peruuta vastaus

Sähköpostiosoitettasi ei julkaista.